Just collection and add some notes.

Abstract from http://androidappdocs.appspot.com/sdk/index.html

Eclipse IDE

  • Recommended versions: Eclipse 3.4 (Ganymede) or 3.5 (Galileo)

Caution: There are known issues with the ADT plugin running with Eclipse 3.6. Please stay on 3.5 until further notice.

  • Eclipse JDT plugin (included in most Eclipse IDE packages)
  • Several types of Eclipse packages are available for each platform. For developing Android applications, we recommend that you install one of these packages:
    • Eclipse IDE for Java EE Developers
    • Eclipse IDE for Java Developers
    • Eclipse for RCP/Plug-in Developers
    • Eclipse Classic (versions 3.5.1 and higher)
  • JDK 5 or JDK 6 (JRE alone is not sufficient)
  • Android Development Tools plugin (optional)
  • Not compatible with Gnu Compiler for Java (gcj)

My workspace: Eclipse 3.5.1 Galileo (include JDT plugin)+ JDK 1.5.0_15 + SDK (update to version 7)

One Comment

  1. world wide web says:

    As a net resource for organizations and technology enthusiasts to follow the newest and greatest advancements in Unified Communications, IP Telephony, Hosted Communications and VoIP.

Leave a Reply